Browser
Recommendations

Plug-ins

What is a plug-in?

A plug-in is a block of code that is integrated into Yandex.Browser and expands its features. In contrast to extensions, a plug-in does not normally have an interface. Plug-ins are used for playing video and audio in the browser, viewing PDF documents, improving the operation of web services, collaborating on projects in the internet, and so on.

Installing a plug-in

Usually, you need to install plug-ins when you visit a site that has a specific type of content (for example, a video). To display this content properly, you must install a plug-in.

Yandex.Browser informs you that a certain plug-in needs to be installed and offers to install it. You will see a notification in the upper part of the page. You will need to download the latest version of the plug-in from the developer's website and install it yourself.

How do I disable a plug-in?

  1. click the icon  Settings.
  2. In the lower half of the Settings page, click Show advanced settings.
  3. In the Privacy section, click Content settings.
  4. In the window that opens, find the Plug-ins section and click Disable individual plug-ins.

  5. The Plug-ins page opens, where all installed plug-ins are listed. To disable a plug-in, click the Disable link under its name.

How do I remove a plug-in?

You cannot delete an installed plug-in from the Yandex.Browser interface. You must use the standard features of your operating system for deleting an application. Go to Control PanelPrograms and components and delete the unwanted plug-in.

Update an outdated plug-in

The plug-in doesn't update automatically and may become outdated. Yandex.Browser determines which plug-ins are outdated and send you a message under your address bar:

  • To install the latest version o f a plug-in, select Update plug-in.
  • If you want to continue running the plug-in without upgrading, click Run this time. The next time you start Yandex.Browser, you will see a message that the plug-in is blocked.
embedded modules
plugins
extensions
plug-ins
plugin