Enabling UnityAds

  1. Supported ad formats
  2. Integration

Supported versions of libraries and platforms:

YandexMobileAdsSDK

Minimum supported version: 2.19.0.

Maximum supported version: 2.20.0 (up to but not including).

UnityAdsSDK

Minimum supported version: 3.4.8.

Maximum supported version: 3.5.0 (up to but not including).

iOS

Minimum supported version: 9.0.

Supported ad formats

Integration

To work with UnityAds, you need to connect the UnityYandexMobileAdsAdapters library.

The UnityYandexMobileAdsAdapters library has been adapted to work with the CocoaPods dependency management system and supports two integration methods: static and dynamic. Select the same integration method for the adapters that was used when connecting the YandexMobileAds SDK.

To connect the library, add the dependency to the project's Podfile:

pod 'UnityAdsYandexMobileAdsAdapters', '0.9.0'
If you don't use CocoaPods
  1. Connect the UnityAds SDK to the project.
  2. Download the UnityAds adapter and add it to the project.
  3. Make changes to the Build Settings file: in Framework Search Paths, add the path to the directory that contains the framework with the adapters.

Integration examples