Enabling MoPub

  1. Supported ad formats
  2. Integration

Supported versions of libraries and platforms:

YandexMobileAdsSDK

Minimum supported version: 2.180.

Maximum supported version: 3.0 (up to but not including).

AppMetricaSDK

Minimum supported version: 3.8.0.

Maximum supported version: 4.0.0 (up to but not including).

MoPubSDK

Minimum supported version: 5.12.0.

Maximum supported version: 5.12.1 (up to but not including).

Supported ad formats

Integration

Add the following dependencies to the build.gradle file at the application level:
implementation 'com.yandex.android:mobileads:2.180'
implementation 'com.yandex.android:mobmetricalib:3.14.3'
implementation 'com.yandex.ads.mediation:mobileads-mopub:1.7.0'
implementation 'com.mopub:mopub-sdk:5.12.0@aar'